Sega Saturn Development > General Jo Engine Help

Running Jo-Engine Applications on Actual Hardware

(1/3) > >>

Mr. Potatobadger:
Hello. Today, I got an Action Replay cart so I can play Saturn Backups as well as my homebrew games made in Jo-Engine on actual hardware, using Pseudo Saturn. I assumed it would work just fine to run applications made with jo engine, but it doesn't. Jo Engine games burned to a CD-R only work using the Swap Trick. Backups of my Sega Saturn games burned to CD-R's work fine with just the cartridge.

According to this video, it should work just fine:

 I used the same Pseudo Saturn version as in the video, yet after booting my Sega Saturn, I go to a blank screen.

I've tried burning the demo1 with the .iso file, the .cue file, and the .bin file, however none of them work. I've also tried the Saturn CD Patching tool (which has been mentioned on another thread on this site), which also did not help.

I'm really hoping someone knows how to run Jo-Engine games with Sega Saturn, it would be really awesome to see my progress on my actual Saturn hardware.

Cheers! :D


I noticed something. I'm not sure if I've made a mistake, or if I have an incorrect setting somewhere? But the demos for the Ship and for the Sonic Game are NOT the same as what I see on this page:

For example, this is all I see for this Shooter demo:

And in the Sonic Demo, it's missing the waterfall, the running animation, the HUD, and it has a different tile layout. Do I somehow have an older version? Could this be the reason why my games will not run with Pseudo Saturn? I'm confused!

Hi Mr. Potatobadger,

Please update the source code from the SVN.

Warning, you have to change your makefile (see instruction in jo/conf.h) or demo makefiles

Mr. Potatobadger:
Still having issues after updating makefile. Burnt games made using Jo Engine still work using the swap trick, but I absolutely hate doing the swap trick. Pseudo Saturn is what I prefer to use. When I use Pseudo Saturn's debugger, I get a screen that says, "CPU Adress Error", with a list of all of the Saturn's registers, followed by hex.

Any ideas?

Unfortunately, I don't have this problem  :-\

Same problem here. Pseudo Saturn is probably the easiest way to try homebrews, hopefully we will find a solution. Did anyone try to talk with the creators of Pseudo Saturn?


[0] Message Index

[#] Next page

Sitemap 1 2 3 4 5 6 7 8 9 10 
Go to full version