Author Topic: More on ZTP  (Read 282 times)

ponut64

  • Full Member
  • ***
  • Posts: 180
  • Karma: +13/-0
    • View Profile
More on ZTP
« on: May 26, 2018, 03:40:17 pm »
Hello mostly XL2,

As your tool is a work-in-progress I'd like to share a project file where I am having some issues.

Some models exported from my animations to be converted in to ZTP files are not loading. This seems non-nonsensical, as the only thing that has changed about the model is its pose.
Another conundrum is it happens in a way spread out across the range of entities. Some in a range stop loading, then models start loading again, then they have problems again.
There is something wrong with my OBJ files and I am not sure what it is.

The issue can be found in &entities[5] through to &entities[10] (and other sequences). In the binary model converter folder (starting from top level), this is RTURP05 to RTURP10. It does NOT happen for those same frames when mirrored (pose copied from L bones to R bones, some other numbers inverted some not, then exported as OBJ) on LTURN05 to LTURN10 / &entities[15] to &entities[20]. Should be noted that the LTURN is the original animation that was copied.

Thank you for reading.

XL2

  • Sr. Member
  • ****
  • Posts: 344
  • Karma: +77/-1
    • View Profile
Re: More on ZTP
« Reply #1 on: May 26, 2018, 03:55:44 pm »
I'm not sure I understand what your problem is, but some ideas :
-When you load, put gouraud at off, else it will overflow.
-The vertices order could be different from one Obj file to the next, which can cause issues.
-Make sure you don't load over 1 MB in total.
-You have too many files in your root folder, causing issues (like 20-25 files or folders).

ponut64

  • Full Member
  • ***
  • Posts: 180
  • Karma: +13/-0
    • View Profile
Re: More on ZTP
« Reply #2 on: May 26, 2018, 04:25:52 pm »
The problem is some models (as frames of an animation, but they are models all the same) do not display and/or load. There's something wrong with how I convert them.

- IIRC slInitGourad would be what you are talking about, and it is the last thing that main does.
- I was afraid that Blender would do that.
- 564 KB is being loaded to the best of my knowledge
- I changed the directory order and ... i think that was it, gimme a sec

/e: Yes, it was too many files in the same directory. Thanks for the tip. I figured it was something simple.
I do wonder what the upper limit really is because some animations may end up being around 30 frames.
Eh, things can always be chunked up.
As always I appreciate what you do.
« Last Edit: May 26, 2018, 04:33:55 pm by ponut64 »

XL2

  • Sr. Member
  • ****
  • Posts: 344
  • Karma: +77/-1
    • View Profile
Re: More on ZTP
« Reply #3 on: May 26, 2018, 07:06:04 pm »
About gouraud, I meant when you do ztLoad3dModel, the last option is to use gouraud or not. Just set it to 0 (off) as you will overflow the limit and erase textures.

 

Sitemap 1 2 3 4 5 6 7 8 9 10 
SMF spam blocked by CleanTalk