Author Topic: Problem with large background image  (Read 367 times)

SaturnTeam

  • Newbie
  • *
  • Posts: 22
  • Karma: +2/-0
    • View Profile
    • Saturn Team
Problem with large background image
« on: November 01, 2017, 06:04:41 pm »
This post has been transferred from my own forum. I've deleted this from my forum.
I am having a problem with adding a background that is quite a bit larger than the demo background. It won't display in Yabause. Jo code error return says "In jo_fs_read_file(): BG.TGA: Out of memory. In jo_free(): Null pointer". It seems to be an issue with either the file size, resolution, or number of colors. I'll update this post when I find the solution.
------------------
It turned out to be an issue with the resolution. Jo Engine, in the .conf file, does list the max resolution, but seems to be defaulting to the "else" statement and using the standard resolution. I found a workaround. I re-saved the background file as half the dimensions. Then, in the Map Editor, I set it to 2x zoom. This came back in Yabause with no errors. However, the image looks terrible, because it's stretched to twice its size. I am still trying to come up with a better solution. It also works if it's on no zoom. I also tried to set my demo file as NTSC 480p (interlaced), but I found out that Yabause doesn't do HD Interlaced, so I'll have to test it on actual Saturn hardware.
« Last Edit: November 01, 2017, 06:44:18 pm by SaturnTeam »
Founder of Saturn Team

 

Sitemap 1 2 3 4 5 6 7 8 9 10 
SMF spam blocked by CleanTalk