Author Topic: "Couldn't reserve space for cygwin's heap, Win32 error 0"  (Read 90 times)

Mr. Potatobadger

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
"Couldn't reserve space for cygwin's heap, Win32 error 0"
« on: September 20, 2017, 04:41:27 am »
I get this weird error when I try to build my Jo game now...

I'm not sure what to do, as none of the solutions I've found online have worked...



I'm stuck, man  :'(

mindslight

  • Administrator
  • Full Member
  • *****
  • Posts: 121
  • Karma: +0/-0
    • View Profile
    • Jo Engine
Re: "Couldn't reserve space for cygwin's heap, Win32 error 0"
« Reply #1 on: September 20, 2017, 07:14:36 am »
Hi,

Restart your PC. It's a shared memory issue, but I can't fix it (not in my code)  :)

Mr. Potatobadger

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: "Couldn't reserve space for cygwin's heap, Win32 error 0"
« Reply #2 on: September 21, 2017, 07:19:22 am »
Restarting my PC is the first thing I did

No luck :(

mindslight

  • Administrator
  • Full Member
  • *****
  • Posts: 121
  • Karma: +0/-0
    • View Profile
    • Jo Engine
Re: "Couldn't reserve space for cygwin's heap, Win32 error 0"
« Reply #3 on: September 21, 2017, 08:30:33 am »
Did you reinstall the SDK ?

Mr. Potatobadger

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: "Couldn't reserve space for cygwin's heap, Win32 error 0"
« Reply #4 on: September 27, 2017, 11:39:14 pm »
What do you mean by SDK? Jo itself? The compiler? If so, then yes, I gave it a fresh install of Jo.

mindslight

  • Administrator
  • Full Member
  • *****
  • Posts: 121
  • Karma: +0/-0
    • View Profile
    • Jo Engine
Re: "Couldn't reserve space for cygwin's heap, Win32 error 0"
« Reply #5 on: September 28, 2017, 08:28:49 am »
Something I found in the Internet:

Quote
This requires one to change the Virtual Memory settings under Win 7 (Control Panel\System and Security\System > Advanced Systems Setting). On the "Advanced" tab, click on the performance "Settings" button - select advanced tab, and click on the "Change ..." button. Enter a custom size value as follows:
Initial Size (MB) = Currently Allocated (shown at the bottom)
Maximum Size (MB) = Recommended (shown at the bottom)

Click on "Set" button, click "OK" and reboot PC to take affect

 

Sitemap 1 2 3 4 5 6 7 8 9 10 
SMF spam blocked by CleanTalk